Atheros AR5212 Wireless on T60 with RHEL5

Madwifi 0.9.4.5 seems to work with this machine, but only after setting mode 2 with iwpriv. Module loads cleanly otherwise, but fails to associate with the network. We see several networks with NetworkManager, but cannot obtain an ip address from any of them. To fix, modify modules.conf to set mode 2 after loading the module.
install ath_pci /sbin/modprobe --ignore-install ath_pci; /sbin/iwpriv ath0 mode 2
After this, we can associate. This also seems persistant across sleeps. RPMS for 2.6.18-8.1.1.el5 RPM kernel-madwifi-0.9.4.5-1.PU_IAS.5_2.6.18_8.1.1.el5.i686.rpm
SRPM madwifi-0.9.4.5-1.PU_IAS.5.src.rpm
Wordpress category: 

Comments

this helped me make my wifi card work in fc6. thank you very much. much obliged.

Add new comment

Markdown

  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <em> <strong> <cite> <blockquote> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Lines and paragraphs break automatically.

Filtered HTML

  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <em> <strong> <cite> <blockquote> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Lines and paragraphs break automatically.

Plain text

  • No HTML tags allowed.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Lines and paragraphs break automatically.
Refresh Type the characters you see in this picture. Type the characters you see in the picture; if you can't read them, submit the form and a new image will be generated. Not case sensitive.  Switch to audio verification.